Aegisub - Audiosync problems.

Read the FAQ in here first then post your questions here if it doesn't help you.
Post Reply
User avatar
citzera
Posts: 11
Joined: Apr 2nd, '08, 19:24
Location: Sweden
Contact:

Aegisub - Audiosync problems.

Post by citzera » Jul 5th, '09, 16:46

Usually when I load audio from the video in Aegisub it's all good to go.
This time when I loaded the audio there suddenly was an additional 9 seconds of nothing added where the video was put together before.
(Original file was .avi. Cut out two parts using Virtualdub and appended them together.)

My problem looks like this. This is what happens when I load audio through "Open Audio from Video":
http://i39.tinypic.com/wkjr4y.jpg

Since a 9 sec gap is kind of a bother when timing using audio I ripped the audio into a .mp3 file and loaded that. Now there's a 95ms gap instead.
http://i40.tinypic.com/r20z5x.jpg
(As picture states, ripping .wav from video using VirtualDub still gave me the 9sec gap)

1. Extracted .mp3 file in Virtualdub. It has exactly the same lenght as the video. It is only when I load that into Aegisub that it is suddenly 9 sec longer.
2. Extracted .wav with VirDub. Output is 9 sec longer than video. Still the same gap in Aegisub.
3. Extracted .mp3 using Format Factory. Extracted it is 95ms longer than original video. Same gap when loaded into Aegusib.

Is there any way to cut away that part of the audio in Aegisub?
Since the first .mp3 file isn't wrong until loaded into Aegisub...
Or should I just give up on the first 1m14s of the video and.. well, only sub the other part?

This is the first time an appended video has ever done this in Aegisub. I can't think of anything I did wrong when cutting/appending. I've tried playing the video in VLC, MPC, WMP and the audio is played properly in all.

- - -
I think that covers it. [/b]

User avatar
XrayMind
Global Moderator
Global Moderator
Posts: 528
Joined: May 2nd, '04, 20:33
Location: Land of the Sub-Prime

Post by XrayMind » Jul 6th, '09, 19:47

It could be either the way the mp3 muxed into the .avi file or the mp3 it's could be corrupted. Somehow the index in the .avi file is keeping everything in sync. But playing the mp3 alone, the bad part is being interprete as 9 seconds of silence. Remember mp3 is lossy COMPRESS format, it will not actually store silence period. Just like zip won't store blank spaces in a text file.

Anyway, if you are just using the audio for timing and since the avi is fine, just load the mp3 in Audacity or any audio editor, remove the silence part, and save it as wav or mp3 for your timing.
Please do not PM me about seeding any of my old torrents, as most of files that had uploaded are no longer on my computer.

User avatar
Keiko1981
Global Moderator
Global Moderator
Posts: 5795
Joined: Apr 9th, '06, 11:27
Location: Sweden
Contact:

Post by Keiko1981 » Jul 28th, '12, 23:41

I have a little problem with the RAW video of Bok Hee E007 720p-HANrel.
All these purple lines you see in the below picture, I think they're one you see when a scene changes.
But in this video I see them all over the timeline, it makes it little bit hard to time.
Is there some way I can hide these lines temporarily?
Image
Sorry, discovered I may I have posted in the wrong thread.
I found the solution for it.
Go to the menu "View" -> Options...
Go under "Audio" -> "Display"
Uncheck "Draw keyframes"
FORUM RULES <- Updated September 2018

Gifted OnesTwitter MyDramaList.com

Ongoing Projects
Asaki Yumemishi, Dairenai, Inochi, Oshin, Seoul 1945

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests