How to convert Japanese ASCII to Unicode?

Read the FAQ in here first then post your questions here if it doesn't help you.
Post Reply
nom_nommi
Posts: 3
Joined: May 24th, '13, 02:40

How to convert Japanese ASCII to Unicode?

Post by nom_nommi » May 24th, '13, 03:12

:-( I am trying to watch and English movie with Japanese subtitles but unfortunately the encoding for the .srt file i downloaded is in ASCII format so whenever I view it on VLC or on notepad it shows like this...

1
00:00:55,620 --> 00:00:57,857

theuncontactable
Fansubber
Fansubber
Posts: 129
Joined: Feb 22nd, '08, 12:53
Contact:

Post by theuncontactable » May 24th, '13, 04:11

You may find the answer in the following thread:

http://www.d-addicts.com/forum/viewtopi ... tm#1282371

saigo_x
Posts: 883
Joined: Nov 4th, '05, 18:14

Post by saigo_x » May 24th, '13, 06:27

Do you have support for asian languages enabled?
http://wiki.openoffice.org/wiki/Documen ... e_settings

nom_nommi
Posts: 3
Joined: May 24th, '13, 02:40

Post by nom_nommi » May 24th, '13, 06:39

theuncontactable wrote:You may find the answer in the following thread:

http://www.d-addicts.com/forum/viewtopi ... tm#1282371
I always use unicode ariel when watching movies etc..

It is the FILE itself that is in ASCII or ANSI not Unicode. The subers were too lazy and din't bother saving it under unicode so it is only "readable" on the Japanese version of windows.

I have Japanese on my pc and type in Japanese on a regular basis.
I just have an English based Windows OS.
saigo_x wrote:Do you have support for asian languages enabled?
http://wiki.openoffice.org/wiki/Documen ... e_settings
Default Languages for documents?
Yes, Japanese is under "Default" for "Asian" languages.
When i try to load it on Open Office it looks like this...

1
00:00:55,620 --> 00:00:57,857
�gŽ„‚Í�iƒtƒ‰ƒ“ƒXŒê�j�h

2
00:00:58,750 --> 00:00:59,830
�g‚ ‚È‚½‚Í�h

3
00:01:01,540 --> 00:01:03,050
�g”Þ‚Í�h

Without having selected as Japanese and opening it as a .srt file on Open office it looks like this... vv
on occasions I see チ, but that is nowhere near what is is meant to be, half width isn't supposed to display on subs...

1 00:00:55,620 --> 00:00:57,857 チgŽ„‚Íチiƒtƒ‰ƒ“ƒXŒêチjチh 2 00:00:58,750 --> 00:00:59,830 チg‚ ‚È‚½‚Íチh 3 00:01:01,540 --> 00:01:03,050 チg”Þ‚Íチh

NoraNeko33
Posts: 45
Joined: Apr 3rd, '12, 00:08

Post by NoraNeko33 » May 24th, '13, 09:08

If you view the Japanese normally open in Aegisub 3.0.2.app the Sub of the problem, you can export in UTF-8 new.

http://www.aegisub.org/

y0ssy
Posts: 228
Joined: Nov 2nd, '09, 09:52

Post by y0ssy » May 24th, '13, 10:18

This subtitle is taken from Subscene and I'd saved it as UTF-8, as attached.
Attachments
Looper.2012.1080p.BluRay.x264.YIFY.srt
(58.51 KiB) Downloaded 65 times

nom_nommi
Posts: 3
Joined: May 24th, '13, 02:40

Post by nom_nommi » May 24th, '13, 11:17

y0ssy wrote:This subtitle is taken from Subscene and I'd saved it as UTF-8, as attached.
thankyouuu thats where I got my sub for Looper :D I also learned how to use Aegisub too. makes conversion really quick and easy. Will be using this program allot. Thanks for helping me (very fast too) <3

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest