DramaWiki image issue

Read the FAQ in here first then post your questions here if it doesn't help you.
koshonin
Posts: 360
Joined: Wed Nov 26, 2014 6:51 pm

DramaWiki image issue

Postby koshonin » Tue Mar 03, 2015 8:03 am

when loading http://wiki.d-addicts.com/Spy I get a 'hotlink-pic' instead of the the picture for the drama and reloading doesn't help.
I think it's the first time I've seen this
Last edited by MoerkJ on Tue Mar 03, 2015 5:19 pm, edited 1 time in total.
Reason: changed topic title

User avatar
whiteadamas
Posts: 150
Joined: Fri Feb 03, 2012 7:26 am

Re: wiki issue

Postby whiteadamas » Tue Mar 03, 2015 10:44 am

Mine is showing the right photo for the spy,

but it does happen to some older post, I have seen the hotlink-pic as well just a few days ago while searching for some older drama and celebs

MoerkJ
Administrator
Administrator
Posts: 1813
Joined: Sat Dec 06, 2003 8:40 am
Location: Germany

Re: DramaWiki image issue

Postby MoerkJ » Tue Mar 03, 2015 5:17 pm

Thanks for noticing. I cannot re-create this bug at the moment. But I will investigate this further.

Usually you'll see the hotlink pic only if the referer is not DramaWiki or this forum. Maybe it's a proxy issue.
Did you accessed the "Spy" page through another website which hotlinked the Spy image? (If yes, then doing a forced refresh of the DramaWiki page should fix this issue.)
Or do you use a proxy or any strange browser plugins when accessing DramaWiki?

User avatar
Keiko1981
Global Moderator
Global Moderator
Posts: 8031
Joined: Sun Apr 09, 2006 11:27 am
Location: Sweden
Contact:

Re: DramaWiki image issue

Postby Keiko1981 » Tue Mar 03, 2015 5:28 pm

I have the same issue with GTO (I noticed it yesterday.)
http://wiki.d-addicts.com/Great_Teacher_Onizuka
Edit And http://wiki.d-addicts.com/Oshin

FireFox v 36.0
I disabled all addons/forced refresh/cleared cache, and the problem still remain. :scratch:
:w00t: Vote for Jdrama of the Week :w00t:

Gifted Ones | Twitter | UL @ Nyaa
Subbing: Ashi Girl, Inochi, Oshin, Seoul 1945, Takane no Hana
Where to find dramas & subtitles

saigo_x
Posts: 1317
Joined: Fri Nov 04, 2005 6:14 pm

Re: DramaWiki image issue

Postby saigo_x » Tue Mar 03, 2015 5:33 pm

I see the same thing. No proxy and same issue whether I use Firefox with plugins or Chrome without.

MoerkJ
Administrator
Administrator
Posts: 1813
Joined: Sat Dec 06, 2003 8:40 am
Location: Germany

Re: DramaWiki image issue

Postby MoerkJ » Tue Mar 03, 2015 8:57 pm

I got the same error for the GTO page (and a few others) when I access DramaWiki through the CloudFlare proxy. :-(

The anti-hotlink settings don't seem to work properly with the CloudFlare proxy we use.
Strange is that it only breaks some images and not all. :scratch:
I turned the hotlink protection off...

P.S.: CloudFlare still may send some wrongly cached images with the hotlinking text.

koshonin
Posts: 360
Joined: Wed Nov 26, 2014 6:51 pm

Re: DramaWiki image issue

Postby koshonin » Tue Mar 03, 2015 11:25 pm

thanks MoerkJ for looking into this and also for changing the thread title,
and all the others that eased my mind that something might be wrong on my end

I think the reason that we all get different results is because cloudflare as a cdn, is serving different geolocations from different servers.

for the reason why the hotlink-prevention-tool is triggered you probably need to look into the code and the server logs;
I'm speculating here: it might happen that the page is served from one proxy while the picture is fetched by another

MoerkJ, maybe you don't need to turn it off or rather tell cloudflare the rules:
https://support.cloudflare.com/hc/en-us ... ection-do-

I would be interested how this will be finally solved (cloudflare/plugin/both, easy/awful)

thanks for keeping it all running


Who is online

Users browsing this forum: No registered users and 2 guests